А кто пользовался sysprep на Win7 ?

  • Алекс7
  • 30 марта, 23:09
  • Просмотров: 45
Третий день пытаюсь мигрировать систему со старого на новый комп. Есть мелочи в плане работы, но в целом все встает после некоторых манипуляций руками. Остается отвязаться от оборудования по нормальному, чтобы всякие ID стали уникальные.

И вот тут засада полная. Sysprep исполняется, но при перезагрузке вылет тут же после сообщений о правке реестра и переходе к запуску служб. Переотключал все службы, что пришло в голову. Удалил в реестре записи, на которые ругался лог ошибок sysprep. Удалял касперского и другие программы... В общем, осталось только проплясать с бубном вокруг. :)

Я бы понял, если бы сам sysprep завершался ошибкой (все же не типичная установка была, профили пользователей на отдельном диске, зачем - так надо было). Но он все исполняет бодро, после чего системе трындец.

Пробовал клонировать и запускать на другой машине, потом sysprep. Пробовал на старой машине sysprep с переносом диска в новый. Пробовал просто на старой машине sysprep. :) Везде один результат.

Может кто знает, как искать место затыка? Рецепты смотрел, но что-то не помогает ничего.
в общем, видимо, мешает users на d Рушится на этапе windeploy, конкретной ошибки нет, только код завершения. Но не он вроде sid меняет, и если пройти дальше вручную, вижу, что у папки пользователей не поменялись sid'ы в настройках безопасности, стоят старые, ставшие "неизвестными пользователями".
я сторонними утилитами acronis Univeral Restore
Paragon p2p migration tool
С LiveCD загружаешься на новом компе, он прям там и вырезает "ненужные" драйвера, чтоб грузилось
запустить и так можно :) Я без всяких утилит спокойно запустил систему, ну немного пошаманил руками на первом этапе, но это чтобы выкосить левые сервисы от старой матери.

А вот заменить SID и всякие GUID и другие ID... Т.к. стоило диск подключить к старой машине, чтобы логи посмотреть, так получил предупреждение, что моя винда не является подлинной. Хотя она лицензионная. Хорошо, что после перезагрузки все вернулось. :)
могу предложить пару вариантов перенести акронисом. емнип там была опция по переносу на другое железо.

Почистить реестр,уже на новом железе, загрузившись с винПЕ.(этот способ я сам пробовал, когда умерла старая материнка и сиспреп уже не на чем было делать)
++++++++++++++++++++++++++++

Запускаем редактор реестра.
Сначала удаляем ветку реестра HKLM\SYSTEM\MountedDevices

Далее включаем запуск сервисов, загружающих стандартные драйвера контроллеров IDE иSATA.
Для этого раскрываем ветку HKLM\SYSTEM\CurrentControlSet\services заходим в раздел amdide.
Находим параметр Start и выставляем его значение 0х00000000 (0), если оно иное
(Start=0 — запуск сервиса при загрузке windows) Для этого дважды кликаем на имени параметра Start и
заменяем значение на 0 (ноль) и жмем ОК. Так же поступаем в разделах:
amdsata, amdxata, atapi, intelide, msahci, pciide
После окончания правки закрываем редактор реестра, перезагружаем компьютер в нормальном режиме и
устанавливаем драйвера.

В принципе для запуска этого достаточно и у меня дополнительной правки не требовалось,
но в случае если это не помогло загружаемся еще раз и правим параметр Start в следующих сервисах:
adp94xx, adpahci, adpu320, aic78xx, amdsbs, arc, arcsas, elxstor, HpSAMD, iaStorV, iirsp,
LSI_FC, LSI_SAS, LSI_SAS2, LSI_SCSI, megasas, MegaSR, nfrd960, nvraid, nvstor, ql2300, ql40xx,
SiSRaid2, SiSRaid4, vhdmp, vsmraid, aliide, cmdide, nvraid, viaide.
++++++++++++++++++++++++
да что-то в акронисах нет опции "перенос" Не уверен я, что Universal Restore удаляет все ID. К тому же... Оно вылетает на новой машине при нажатии ОК. :) Даже не пытается начать. Разве что планомерно пробовать разные версии.

Я так понимаю, что проблема не в устройствах. Сервисы же не только за дрова отвечают, а я удалил все "специфические" дрова наа новой машине.

Да и на старой - там вообще все совпадать должно... Все советы сводились к тому, что мешает некое виртуальное оборудование, типа виртуальных DVD, антивирусов... А я снес и Каспа, и vmware, виртуальных дисков нет. Удалил ПО мониторинга от материнки. Выключил все левые службы временно, кроме МС и Интел...

Если бы можно было понять, в каком логе sysprep пишет ошибку свою. Т.к. в его папке только логи работы, они не меняются при попытке загрузки.
написал выше про Парагон Где Акронис не справляется, Парагон может
просто мне не клон создать надо, а "новую" винду Просто на всякий случай насчет акрониса - мне нужно, чтобы два компа с тем же ПО считались разными в плане всех GUID и работали в одной сетке. Как раз что делает sysprep...
ааа тогда парагон идет лесом
Re: В свое время, для клонирования активно использовал утилитку NewSID. Все клоны в домене работали нормально.
на нее есть нарекания все же
Re: на нее есть нарекания все же Я не сталкивался. В районе 30 виртуалок Hyper-V, в домене. Потом, правда перешли на vmware, там при развертывании шаблона уже встроено все, включая ввод в домен.
Я немного про нее прочитал, включая "от автора" у него так и не было 100% уверенности в том, что она все SID исправляет. Уже на Vista были глюки.